Events 3.0 and FileMaker Pro 7

No. If you are planning to use the Events plug-in in FileMaker Pro 7, you must upgrade to Events 4.